comp.lang.idl-pvwave archive
Messages from Usenet group comp.lang.idl-pvwave, compiled by Paulo Penteado

Home » Public Forums » archive » Re: iTool interaction with IDLgrModel / IDLgrPolygon member properties?
Show: Today's Messages :: Show Polls :: Message Navigator
E-mail to friend 
Switch to threaded view of this topic Create a new topic Submit Reply
Re: iTool interaction with IDLgrModel / IDLgrPolygon member properties? [message #37236] Sun, 07 December 2003 18:21
sdettrick is currently offline  sdettrick
Messages: 14
Registered: December 2003
Junior Member
David Fanning <david@dfanning.com> wrote in message news:<MPG.1a3ab40e2b3dffa4989770@news.frii.com>...
> Sean Dettrick writes:
>
>> i've got a bunch of 3D IDLgrPolygon objects stuck into an IDLgrModel.
>> I have been visualizing them to date with xobjview. I find that I can
>> import the model into, for example, iPlot via the pull-down menu.
>>
>> My question is, what do I have to do to make it so that I can edit the
>> properties of the polygon objects (colors, alpha, hide/show, shading
>> etc) from within the iTool? Do I have to write my own iTool app, or
>> can I just provide extra info on my polygon objects for an iTool to
>> access?
>>
>> I would appreciate any advice.
>
> I haven't tried this, but it would be neat if it worked.
> Have you tried just setting the REGISTER_PROPERTIES
> keyword when you create your POLYGON objects? That
> might do it all. Otherwise, I'd have a look at the
> IDLitComponent object, your polygons are subclassed
> from this.
>
> Cheers,
>
> David

Hi, yes, I tried that. I put /REGISTER_PROPERTIES as a keyword into
every object in my model that would allow the code to compile
(something, maybe IDLgrText but I'm not sure, wouldn't accept it). It
didn't solve the problem though I should try it again when I'm feeling
a little more patient.

I'll have a look at the IDLitComponent subclassing.

Will post a follow-up if I have any success.

Thanks,
Sean
Re: iTool interaction with IDLgrModel / IDLgrPolygon member properties? [message #37243 is a reply to message #37236] Fri, 05 December 2003 14:26 Go to previous message
David Fanning is currently offline  David Fanning
Messages: 11724
Registered: August 2001
Senior Member
Sean Dettrick writes:

> i've got a bunch of 3D IDLgrPolygon objects stuck into an IDLgrModel.
> I have been visualizing them to date with xobjview. I find that I can
> import the model into, for example, iPlot via the pull-down menu.
>
> My question is, what do I have to do to make it so that I can edit the
> properties of the polygon objects (colors, alpha, hide/show, shading
> etc) from within the iTool? Do I have to write my own iTool app, or
> can I just provide extra info on my polygon objects for an iTool to
> access?
>
> I would appreciate any advice.

I haven't tried this, but it would be neat if it worked.
Have you tried just setting the REGISTER_PROPERTIES
keyword when you create your POLYGON objects? That
might do it all. Otherwise, I'd have a look at the
IDLitComponent object, your polygons are subclassed
from this.

Cheers,

David

--
David W. Fanning, Ph.D.
Fanning Software Consulting, Inc.
Phone: 970-221-0438, E-mail: david@dfanning.com
Coyote's Guide to IDL Programming: http://www.dfanning.com/
Toll-Free IDL Book Orders: 1-888-461-0155
  Switch to threaded view of this topic Create a new topic Submit Reply
Previous Topic: importing variables into iTools programmatically
Next Topic: iTools bugs? cleanup and IDLgrModel import

-=] Back to Top [=-
[ Syndicate this forum (XML) ] [ RSS ] [ PDF ]

Current Time: Sun Nov 29 01:41:25 PST 2020

Total time taken to generate the page: 0.00829 seconds