Subject: Re: Subversion in IDL Workbench
Posted by David Fanning on Sat, 08 Dec 2007 15:58:09 GMT

View Forum Message <> Reply to Message

David Fanning writes:

> Chris Torrence writes:

>

>> Just FYI, the new IDL Workbench (part of IDL7.0) has built-in support

>> for version history. Once you have the new IDL Workbench, you can also
>> download a CVS plug-in from the ITTVIS update site, and there are also
>> plug-ins for Subversion and Perforce:

>>  http://www.eclipse.org/subversive/

>>  http://www.perforce.com/perforce/products/p4wsad.html

V

OK, so | actually use Perforce on this machine, so | thought

| might as well have a go with that. No problem following the
installation directions on the page pointed to with the Perforce
URL above.

| successfully downloaded the plug-in and installed it. | was
asked if | wanted to restart the IDL Workbench. "Sure, why not?"
Now it is up here in front of me and looks EXACTLY like it

used to. | don't find any new buttons, menu items, etc. that
would give me a clue as to what | am suppose to do next.

| guess | naively expected | might have to check a file
out, set up a repository, *something*. | don't even see
a Plug-In menu. Does anyone have more clues for me?

Thanks,

David

David Fanning, Ph.D.

Fanning Software Consulting, Inc.

Coyote's Guide to IDL Programming: http://www.dfanning.com/
Sepore ma de ni thui. ("Perhaps thou speakest truth.")

Subject: Re: Subversion in IDL Workbench
Posted by Michael Galloy on Sat, 08 Dec 2007 18:19:01 GMT

View Forum Message <> Reply to Message

On Dec 8, 8:36 am, David Fanning <n...@dfanning.com> wrote:
> OK, I've heard so much about Subversion | decided to install it
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and see what this is all about. I'm running IDL 7.0 on Windows XP Pro
with all the latest security patches, etc.

| go to the Subversive page, as described above. | find directions
for installing the Eclipse plug-in:

http://www.eclipse.org/subversive/documentation/gettingStart ed/aboutSubv
ersive/install.php

| am instructed to add a New Update Site. | successfully add
Subversive, with the "proper URL" :

http://www.eclipse.org/subversive/downloads.php
Next, | am suppose to add Subversive SVN Connectors. However,

it has the *same* "proper URL" as the first site, and Eclipse
won't allow me to enter it.

VVVVVVVVVVVVVYVYVYVYV

If you are still interested in Subversion plugins...

| use Subclipse not Subversive. Subversive is newer and (supposedly)
better, but Subclipse handles my requirements well.

Any way, | think the connectors are at:
http://www.polarion.org/projects/subversive/download/eclipse /2.0/update-site/

Mike
www.michaelgalloy.com
Tech-X Corporation
Software Developer Il

Subject: Re: Subversion in IDL Workbench
Posted by Vince Hradil on Sat, 08 Dec 2007 18:19:24 GMT

View Forum Message <> Reply to Message

On Dec 8, 9:58 am, David Fanning <n...@dfanning.com> wrote:

> David Fanning writes:

>> Chris Torrence writes:

>

>>> Just FYI, the new IDL Workbench (part of IDL7.0) has built-in support
>>> for version history. Once you have the new IDL Workbench, you can also
>>> download a CVS plug-in from the ITTVIS update site, and there are also
>>> plug-ins for Subversion and Perforce:

>>> http://www.eclipse.org/subversive/

>>> http://www.perforce.com/perforce/products/p4wsad.html

>

V
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OK, so | actually use Perforce on this machine, so | thought

| might as well have a go with that. No problem following the
installation directions on the page pointed to with the Perforce
URL above.

| successfully downloaded the plug-in and installed it. | was
asked if I wanted to restart the IDL Workbench. "Sure, why not?"
Now it is up here in front of me and looks EXACTLY like it

used to. | don't find any new buttons, menu items, etc. that
would give me a clue as to what | am suppose to do next.

| guess | naively expected | might have to check a file
out, set up a repository, *something*. | don't even see
a Plug-In menu. Does anyone have more clues for me?

Thanks,

David

David Fanning, Ph.D.

Fanning Software Consulting, Inc.

Coyote's Guide to IDL Programming:http://www.dfanning.com/
Sepore ma de ni thui. ("Perhaps thou speakest truth.")

VVVVVVVVVVVVVVVVYVYVVYVYVYVYVYV

| tried both subclipse and subversive - | chose subclipse. | had some

problems with subversive, but sorry | can't remember the detalils,

except that removing the plugins was a bit of pain. | ended up

"rolling back" to the original plugin setup and re-installing

subclipse (luckily this was only a day into IDL7). Among the things |

read regarding this issue was: http://www.barneyb.com/barneyblog/2006/10/26/subclipse-vs-su
bversive/

Your mileage may vary...

Also, | think that either of these plugins requires that you install
and maintain subversion itself separately. That's pretty easy,
really, I might be able to help if someone needs help, but there are
plenty of better resources out there.

Subject: Re: Subversion in IDL Workbench
Posted by Michael Galloy on Sat, 08 Dec 2007 18:24:30 GMT

View Forum Message <> Reply to Message

On Dec 8, 8:58 am, David Fanning <n...@dfanning.com> wrote:
> David Fanning writes:

>> Chris Torrence writes:

>
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V

>>> Just FYI, the new IDL Workbench (part of IDL7.0) has built-in support
>>> for version history. Once you have the new IDL Workbench, you can also
>>> download a CVS plug-in from the ITTVIS update site, and there are also
>>> plug-ins for Subversion and Perforce:

>>> http://www.eclipse.org/subversive/

>>>  http://'www.perforce.com/perforce/products/p4wsad.html

OK, so | actually use Perforce on this machine, so | thought

| might as well have a go with that. No problem following the
installation directions on the page pointed to with the Perforce
URL above.

| successfully downloaded the plug-in and installed it. | was
asked if | wanted to restart the IDL Workbench. "Sure, why not?"
Now it is up here in front of me and looks EXACTLY like it

used to. | don't find any new buttons, menu items, etc. that
would give me a clue as to what | am suppose to do next.

| guess | naively expected | might have to check a file
out, set up a repository, *something*. | don't even see
a Plug-In menu. Does anyone have more clues for me?

VVVVVVVVVYVYVYVYVYVYV

Well, | don't use the Perforce plugin, but the Subclipse Subversion
plugin adds things like:

* a entry in the "New Project" menu that allows you to check out a
project

* context menus for files/directories in a Subversion project that
let you do Subversion actions like update, commit, diff, etc.

* decorators on file/directories that indicate which files have been
changed, what revision they are on, when they were last checked in,
etc.

None of these things are visible until you create a new Subversion
project using "New Project".

| would assume that the Perforce plugin has a similar workflow.

Mike
www.michaelgalloy.com
Tech-X Corporation
Software Developer II

Subject: Re: Subversion in IDL Workbench
Posted by Michael Galloy on Sat, 08 Dec 2007 18:28:42 GMT
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View Forum Message <> Reply to Message

On Dec 8, 11:19 am, Vince Hradil <hrad...@yahoo.com> wrote:

> On Dec 8, 9:58 am, David Fanning <n...@dfanning.com> wrote:

>

>

>

>> David Fanning writes:

>>> Chris Torrence writes:

>

>>>> Just FYI, the new IDL Workbench (part of IDL7.0) has built-in support
>>>> for version history. Once you have the new IDL Workbench, you can also
>>>> download a CVS plug-in from the ITTVIS update site, and there are also
>>>> plug-ins for Subversion and Perforce:

>>>> http://lwww.eclipse.org/subversive/

>>>>  http://lwww.perforce.com/perforce/products/p4wsad.html

>

>> OK, so | actually use Perforce on this machine, so | thought

>> | might as well have a go with that. No problem following the

>> jnstallation directions on the page pointed to with the Perforce
>> URL above.

>

>> | successfully downloaded the plug-in and installed it. | was

>> asked if | wanted to restart the IDL Workbench. "Sure, why not?"
>> Now it is up here in front of me and looks EXACTLY like it

>> used to. | don't find any new buttons, menu items, etc. that

>> would give me a clue as to what | am suppose to do next.

>

>> | guess | naively expected | might have to check a file

>> out, set up a repository, *something*. | don't even see

>> a Plug-In menu. Does anyone have more clues for me?

>

>> Thanks,

>

>> David

>

>> -

>> David Fanning, Ph.D.

>> Fanning Software Consulting, Inc.

>> Coyote's Guide to IDL Programming:http://www.dfanning.com/
>> Sepore ma de ni thui. ("Perhaps thou speakest truth.")

| tried both subclipse and subversive - | chose subclipse. | had some

problems with subversive, but sorry | can't remember the details,

except that removing the plugins was a bit of pain. | ended up

“rolling back" to the original plugin setup and re-installing

subclipse (luckily this was only a day into IDL7). Among the things |

read regarding this issue was:http://www.barneyb.com/barneyblog/2006/10/26/subclipse-v
s-subversive/

V VVVVYVYV
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Your mileage may vary...

>
>
> Also, | think that either of these plugins requires that you install

> and maintain subversion itself separately. That's pretty easy,

> really, | might be able to help if someone needs help, but there are
> plenty of better resources out there.

Yes, if anyone wants a sample Subversion project to check out, use:
http://svn.idldev.com/mgunit
Anyone should be able to checkout (but not commit to) this project.

Mike
www.michaelgalloy.com
Tech-X Corporation
Software Developer II

Subject: Re: Subversion in IDL Workbench
Posted by David Fanning on Sat, 08 Dec 2007 18:49:59 GMT

View Forum Message <> Reply to Message

Mike Galloy writes:

Well, | don't use the Perforce plugin, but the Subclipse Subversion
plugin adds things like:

* a entry in the "New Project" menu that allows you to check out a
project

* context menus for files/directories in a Subversion project that
let you do Subversion actions like update, commit, diff, etc.

* decorators on file/directories that indicate which files have been
changed, what revision they are on, when they were last checked in,
etc.

None of these things are visible until you create a new Subversion
project using "New Project".

VVVVVVVVYVVYVYVYVYVYV

| would assume that the Perforce plugin has a similar workflow.
Well, if it does, | sure can't find it. :-(

Just a warning to Windows user of the Workbench, if you
go to Help->Product Configuration don't click the View
Installation History button. You get a dialog that just
beeps at you no matter which button you click.
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Cheers,
David

David Fanning, Ph.D.

Fanning Software Consulting, Inc.

Coyote's Guide to IDL Programming: http://www.dfanning.com/
Sepore ma de ni thui. ("Perhaps thou speakest truth.")

Subject: Re: Subversion in IDL Workbench
Posted by David Fanning on Sat, 08 Dec 2007 19:02:15 GMT

View Forum Message <> Reply to Message

Vince Hradil writes:

> | can't remember the detalils,
> except that removing the plugins was a bit of pain.

Well, | find when | go to the Update Sites to Visit

menu, select my Perforce Plug-in and click Remove

that the plug-in seems to be removed, but the Finish
button never gets sensitized. After waiting for more

than 10 minutes, | still have a choice of Back or Cancel.
This is what you call being on the horns of a dilemma. :-)

> | ended up
> "rolling back” to the original plugin setup and re-installing
> subclipse (luckily this was only a day into IDL7).

| just went back and reverted to the original installation.
That's a nice feature, except that | notice over a five day
period | haven't made too much progress getting this
interface configured for real work. :-(

Oh, well. I've learned a lot. :-)
Cheers,

David

David Fanning, Ph.D.

Fanning Software Consulting, Inc.

Coyote's Guide to IDL Programming: http://www.dfanning.com/
Sepore ma de ni thui. ("Perhaps thou speakest truth.")
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Subject: Re: Subversion in IDL Workbench
Posted by David Fanning on Sat, 08 Dec 2007 19:07:21 GMT

View Forum Message <> Reply to Message

David Fanning writes:

> Just a warning to Windows user of the Workbench, if you
> go to Help->Product Configuration don't click the View

> [nstallation History button. You get a dialog that just

> beeps at you no matter which button you click.

Well, now | can't get this to fail anymore. Some things
break. Some things get fixed. | just plod on...

Cheers,
David

P.S. Let's just say this version of IDL appears to be
more plugged into the Mystery of Life than any previous
version, in my experience. I'm sure that's a good thing.
At least, that's what | keep telling myself.

David Fanning, Ph.D.

Fanning Software Consulting, Inc.

Coyote's Guide to IDL Programming: http://www.dfanning.com/
Sepore ma de ni thui. ("Perhaps thou speakest truth.")

Subject: Re: Subversion in IDL Workbench
Posted by Vince Hradil on Sat, 08 Dec 2007 19:20:05 GMT

View Forum Message <> Reply to Message

On Dec 8, 12:49 pm, David Fanning <n...@dfanning.com> wrote:

> Mike Galloy writes:

>> Well, | don't use the Perforce plugin, but the Subclipse Subversion
>> plugin adds things like:

>
>> *aentry in the "New Project" menu that allows you to check out a
>> project

>> * context menus for files/directories in a Subversion project that

>> let you do Subversion actions like update, commit, diff, etc.

>> * decorators on file/directories that indicate which files have been
>> changed, what revision they are on, when they were last checked in,
>> etc.

>

>> None of these things are visible until you create a new Subversion
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>> project using "New Project".
>

>> | would assume that the Perforce plugin has a similar workflow.

David Fanning, Ph.D.

Fanning Software Consulting, Inc.

Coyote's Guide to IDL Programming:http://www.dfanning.com/
Sepore ma de ni thui. ("Perhaps thou speakest truth.")

>

> Well, if it does, | sure can't find it. :-(

>

> Just a warning to Windows user of the Workbench, if you
> go to Help->Product Configuration don't click the View
> [Installation History button. You get a dialog that just

> beeps at you no matter which button you click.

>

> Cheers,

>

> David

>

>

>

>

>

| don't have a Help->Product Configuration ?

Subject: Re: Subversion in IDL Workbench

Posted by David Fanning on Sat, 08 Dec 2007 19:28:36 GMT

View Forum Message <> Reply to Message

Vince Hradil writes:
> | don't have a Help->Product Configuration ?
Yeah, I'm getting flustered...

Help -> Software Updates -> Manage Configuration gives a
window that is "labelled" Product Configuration. But all
those buttons work now and are conspiring to make a liar
out of me. :-(

Cheers,

David

David Fanning, Ph.D.

Fanning Software Consulting, Inc.

Coyote's Guide to IDL Programming: http://www.dfanning.com/
Sepore ma de ni thui. ("Perhaps thou speakest truth.")
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Subject: Re: Subversion in IDL Workbench
Posted by Vince Hradil on Sat, 08 Dec 2007 19:38:01 GMT

View Forum Message <> Reply to Message

On Dec 8, 1:28 pm, David Fanning <n...@dfanning.com> wrote:
> Vince Hradil writes:
>> | don't have a Help->Product Configuration ?

David Fanning, Ph.D.

Fanning Software Consulting, Inc.

Coyote's Guide to IDL Programming:http://www.dfanning.com/
Sepore ma de ni thui. ("Perhaps thou speakest truth.")

>

> Yeah, I'm getting flustered...

>

> Help -> Software Updates -> Manage Configuration gives a
> window that is "labelled" Product Configuration. But all

> those buttons work now and are conspiring to make a liar
> out of me. :~(

>

> Cheers,

>

> David

>

>

>

>

>

Well, that is where | had problems with Subversive. There were
actually several separate plugins, maybe 4? Each time | tried to
remove one, it said that it could not be removed because it was
required by some other plugin. | went around in circles like this for
a while, then just "rolled back" and removed files/folders from the
file system. Hack, hack...

Subject: Re: Subversion in IDL Workbench
Posted by David Fanning on Sat, 08 Dec 2007 19:46:17 GMT

View Forum Message <> Reply to Message

David Fanning writes:

> Yeah, I'm getting flustered...

I'm reading that second chapter of Ronn's book, "Don't Panic!"
again right now, and taking slow breaths. It's not helping
much.

Does anyone have ANY idea how the Help system works! Please!

| have windows popping up all over the Universe, apparently.
But | can't make rhyme or reason out of it. How many
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technical writers committed suicide on this project, is
what | am wondering right now. | feel their pain.

Cheers,
David

P.S. Let's just say that bottle of bourbon | bought
to give my neighbor for Christmas is looking more and
more attractive to me today.

David Fanning, Ph.D.

Fanning Software Consulting, Inc.

Coyote's Guide to IDL Programming: http://www.dfanning.com/
Sepore ma de ni thui. ("Perhaps thou speakest truth.")

Subject: Re: Subversion in IDL Workbench
Posted by Michael Galloy on Sat, 08 Dec 2007 21:26:08 GMT

View Forum Message <> Reply to Message

On Dec 8, 11:49 am, David Fanning <n...@dfanning.com> wrote:

> Mike Galloy writes:

>> Well, | don't use the Perforce plugin, but the Subclipse Subversion
>> plugin adds things like:

>
>> * aentry in the "New Project" menu that allows you to check out a
>> project

>> * context menus for files/directories in a Subversion project that
>> |et you do Subversion actions like update, commit, diff, etc.

>> * decorators on file/directories that indicate which files have been
>> changed, what revision they are on, when they were last checked in,
>> etc.

>

>> None of these things are visible until you create a new Subversion
>> project using "New Project".

>

>> | would assume that the Perforce plugin has a similar workflow.

>

> Well, if it does, | sure can't find it. :-(

Yes, it does seem to be different. It seems like you create the
project first and then share it. Try:

http://www.perforce.com/perforce/doc.062/manuals/p4wsad/topi cs/adding.html

Mike
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www.michaelgalloy.com
Tech-X Corporation
Software Developer II

Subject: Re: Subversion in IDL Workbench
Posted by sbolin42 on Sat, 08 Dec 2007 21:54:25 GMT

View Forum Message <> Reply to Message

On Dec 8, 2:26 pm, "mgal...@gmail.com” <mgal...@gmail.com> wrote:
> On Dec 8, 11:49 am, David Fanning <n...@dfanning.com> wrote:

>

>

>

>> Mike Galloy writes:

>>> Well, | don't use the Perforce plugin, but the Subclipse Subversion
>>> plugin adds things like:

>

>>>  * g entry in the "New Project” menu that allows you to check out a
>>> project

>>> * context menus for files/directories in a Subversion project that
>>> |et you do Subversion actions like update, commit, diff, etc.

>>> * decorators on file/directories that indicate which files have been
>>> changed, what revision they are on, when they were last checked in,
>>> efc.

>

>>> None of these things are visible until you create a new Subversion
>>> project using "New Project”.

>

>>> | would assume that the Perforce plugin has a similar workflow.

>

>> Well, if it does, | sure can't find it. :-(

Yes, it does seem to be different. It seems like you create the
project first and then share it. Try:

http://www.perforce.com/perforce/doc.062/manuals/p4wsad/topi cs/adding...

Mike
--www.michaelgalloy.com
Tech-X Corporation
Software Developer II

VVVVYVVVYVYVYV

David,

Working from memory here, since | use Perforce at work but don't
have it here at home. After installing the plugin,
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go to Window->Show View...->Other, then select the Perforce category
and you should see the views it offers. | seem to remember using the
'Server' and 'Changelist’ views. | think you right click in the

Server view and create a connection to your Perforce server first.

Once you've done this, you should see a tree of all your source in the
depot. Then, you can select a folder of source and "add as a

project”, which will grab the code from the server and put it into

your Project Explorer view. When you start editing code, the plugin
will automatically do a checkout into the default changelist.

| can't exactly remember the names of the Perforce views, but hope
this helps to get you going.

-scott

Subject: Re: Subversion in IDL Workbench
Posted by David Fanning on Sat, 08 Dec 2007 23:27:32 GMT

View Forum Message <> Reply to Message

Mike Galloy writes:
> If you are still interested in Subversion plugins...
Sigh...

OK, I am in this whole hog now. I've removed Perforce from
my computer so there was no conflict with Subversion.

| downloaded a Subversion package, and after too many
tries to mention without a great deal of embarrassment,

| have that working outside of the Workbench.

http://svnlclicksetup.tigris.org/

It uses TortiseSVN to work with Subversion via the Window
Explorer. Nice. | like that. And if you set it up right, it

works great. (Here is a tip. If you don't like the way

it gets set up, just delete the SNVRepository directory and
start over. Do it three or four times, if you have the time.

No hurry.)

So, now | am to the part where | am going to install a

Subclipse plug-in to access this Subversion repository
from inside the IDL Workbench. | follow the directions
on this page:

http://subclipse.tigris.org/install.html
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| select the Subclipse 1.2.x (Eclipse 3.2+) instructions,
because | figure out (I don't remember how) | am running
Eclipse 3.3.something.

Eclipse seems to find the repository and gets it over
to my machine OK, but when | go to install it | get a
message that:

"Buckminster - Subclipse support (Incubation) (0.2.0.r3554) requires
plug-in "org.eclipse.buckminster.core”

| try to read up on "org.eclipse.buckminster.core" and | start reading
about "headless" this and "headless" that.

http://wiki.eclipse.org/Sample_headless_configuration_(Buckminster)
Have | stumbled into some kind of a cult here?
Any pointers on what to do next that *doesn't* involve cannibalism?
Cheers,
David

David Fanning, Ph.D.

Fanning Software Consulting, Inc.

Coyote's Guide to IDL Programming: http://www.dfanning.com/
Sepore ma de ni thui. ("Perhaps thou speakest truth.")

Subject: Re: Subversion in IDL Workbench
Posted by Vince Hradil on Sun, 09 Dec 2007 00:07:52 GMT

View Forum Message <> Reply to Message

On Dec 8, 5:27 pm, David Fanning <n...@dfanning.com> wrote:
> Mike Galloy writes:
>> [f you are still interested in Subversion plugins...

Sigh...

OK, I am in this whole hog now. I've removed Perforce from
my computer so there was no conflict with Subversion.

| downloaded a Subversion package, and after too many
tries to mention without a great deal of embarrassment,

| have that working outside of the Workbench.

http://svnlclicksetup.tigris.org/

VVVVVVYVVYVYVYV
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It uses TortiseSVN to work with Subversion via the Window
Explorer. Nice. | like that. And if you set it up right, it

works great. (Here is a tip. If you don't like the way

it gets set up, just delete the SNVRepository directory and
start over. Do it three or four times, if you have the time.

No hurry.)

So, now | am to the part where | am going to install a
Subclipse plug-in to access this Subversion repository
from inside the IDL Workbench. | follow the directions
on this page:

http://subclipse.tigris.org/install.html
| select the Subclipse 1.2.x (Eclipse 3.2+) instructions,
because | figure out (I don't remember how) | am running
Eclipse 3.3.something.
Eclipse seems to find the repository and gets it over
to my machine OK, but when | go to install it | get a
message that:

"Buckminster - Subclipse support (Incubation) (0.2.0.r3554) requires
plug-in "org.eclipse.buckminster.core"

| try to read up on "org.eclipse.buckminster.core" and | start reading
about "headless" this and "headless" that.

http://wiki.eclipse.org/Sample_headless_configuration_(Buckminster)
Have | stumbled into some kind of a cult here?
Any pointers on what to do next that *doesn't* involve cannibalism?
Cheers,
David
-[;avid Fanning, Ph.D.
Fanning Software Consulting, Inc.

Coyote's Guide to IDL Programming:http://www.dfanning.com/
Sepore ma de ni thui. ("Perhaps thou speakest truth.")

VVVVVVVVVVVVVVVVVVVVVVVVVVVVVVVVVVVYVVYVYVYVYVYV

| found a similar issue here: http://www.myeclipseide.com/index.php?name=PNphpBB2&file
=viewtopic&p=87071

Maybe your subversive installation is not completely "cleaned out"?

Maybe try JUST installing the base subclipse - no options?
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Subject: Re: Subversion in IDL Workbench
Posted by David Fanning on Sun, 09 Dec 2007 00:41:17 GMT

View Forum Message <> Reply to Message

Vince Hradil writes:

> | found a similar issue here: http://www.myeclipseide.com/index.php?name=PNphpBB2&file
=viewtopic&p=87071

> Maybe your subversive installation is not completely "cleaned out"?

> Maybe try JUST installing the base subclipse - no options?

Oh, the hell with it. I've wasted enough time today.
Maybe later.

Cheers,

David

David Fanning, Ph.D.

Fanning Software Consulting, Inc.

Coyote's Guide to IDL Programming: http://www.dfanning.com/
Sepore ma de ni thui. ("Perhaps thou speakest truth.")

Subject: Re: Subversion in IDL Workbench
Posted by David Fanning on Sun, 09 Dec 2007 21:14:42 GMT

View Forum Message <> Reply to Message

David Fanning writes:

So, now | am to the part where | am going to install a
Subclipse plug-in to access this Subversion repository
from inside the IDL Workbench. | follow the directions
on this page:

http://subclipse.tigris.org/install.html

| select the Subclipse 1.2.x (Eclipse 3.2+) instructions,
because | figure out (I don't remember how) | am running
Eclipse 3.3.something.

Eclipse seems to find the repository and gets it over
to my machine OK, but when | go to install it | get a
message that:

"Buckminster - Subclipse support (Incubation) (0.2.0.r3554) requires
plug-in "org.eclipse.buckminster.core”

VVVVVVVVVVVVVVYVYVYVYV
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| try to read up on "org.eclipse.buckminster.core" and | start reading
about "headless" this and "headless" that.

http://wiki.eclipse.org/Sample_headless_configuration_(Buckminster)

>
>
>
>
>
> Have | stumbled into some kind of a cult here?
>

>

Any pointers on what to do next that *doesn't* involve cannibalism?

Alright, | appear to have this working now. Here is what | did.

| read somewhere that the "buckminster.core” business might not
even be needed. So | just expanded the "Subclipse 1.2.x" selection
in the Features to Install section and de-selected the Integrations
(Optional) selection, which contained the buckminster.core and
Subslipse Integration for Mylyn options. Then, | just installed
everything else. Went normally.

Then | went to Open Perspective -> Other and found the SVN Repository
perspective and selected that. In the SVN Repository window, | right
clicked, and selected New -> Repository Location. You have to enter

the URL to the repository on your disk. Since mine is just a file

location (I didn't start the Apache server), | just set the URL up

like this:

URL.: file:///C:/Documents and Settings/David/SNVRepository
Now | can see the files | placed into my repository earlier.
Good to go, | guess, although I'm still not quite sure how
to commit files, etc. Still learning. But I'm making some
progress again.
Cheers,
David
David Fanning, Ph.D.
Fanning Software Consulting, Inc.

Coyote's Guide to IDL Programming: http://www.dfanning.com/
Sepore ma de ni thui. ("Perhaps thou speakest truth.")
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