
Subject: Version Control Conundrum
Posted by David Fanning on Sat, 08 Dec 2007 17:29:21 GMT
View Forum Message <> Reply to Message

Folks,

While I wait for someone to help sort out my problems
with Subversion and Perforce plug-ins for the IDL Workbench
(see other posts today), I had the opportunity to make
a change in another file that I have under Perforce
control.

IDL 6.4, if I open this file, and try to make changes
to it, IDL will refuse to write it, as Perforce has made
it read-only, and rightly so. I have to get over into
Perforce and open it for editing before IDL will write
it. Perfect.

In IDL 7.0, the Workbench noticed that this file is
read-only and just asks me if I want to change it anyway.
"Sure, what the hell. Save me some time." And it just
writes it!!! Perforce doesn't know a damn thing about it.

I'm not a big version control expert, but this don't seem
right. :-(

Cheers,

David
-- 
David Fanning, Ph.D.
Fanning Software Consulting, Inc.
Coyote's Guide to IDL Programming: http://www.dfanning.com/
Sepore ma de ni thui. ("Perhaps thou speakest truth.")

Subject: Re: Version Control Conundrum
Posted by David Fanning on Mon, 10 Dec 2007 14:45:09 GMT
View Forum Message <> Reply to Message

cgpadwick@gmail.com writes:

>  I experimented with the eclipse perforce plugin for a while.  I don't
>  recommend it.  I found it confusing and hard to use.  The eclipse
>  perspectives are not a good interface for this type of thing.   What I
>  would like to do is right click my file in the project and check it
>  out or submit it, but with the perforce plugin you have to change
>  perspectives. The perforce ui, p4v, is MUCH easier to use.
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Well, unless I am missing something (likely), you have to 
change perspectives to work with the Subclipse plug-in, too.

This could be made a lot less onerous if I could somehow
put the SNV Repository perspective in the *top* of the
Open Perspective menu instead of always having to choose
Other to get there, and then having to choose Other again
to get back to the IDL perspective. I have a feeling this
is probably a configurable item, but if so, I haven't found
the right magical incantation to make it happen.

Cheers,

David
-- 
David Fanning, Ph.D.
Fanning Software Consulting, Inc.
Coyote's Guide to IDL Programming: http://www.dfanning.com/
Sepore ma de ni thui. ("Perhaps thou speakest truth.")

Subject: Re: Version Control Conundrum
Posted by David Fanning on Mon, 10 Dec 2007 14:51:30 GMT
View Forum Message <> Reply to Message

David Fanning writes:

>  Well, unless I am missing something (likely), you have to 
>  change perspectives to work with the Subclipse plug-in, too.

Incidentally, about every other time I do this (and in
particular if I start up in the SNV Repository perspective
and want to switch to the IDL perspective), I throw an
error. The only way I have found I can then work, is to
start the Workshop all over again and go get another cup
of coffee while it "analyses code". I seem to be spending
more time in the bathroom than at my computer these days. :-(

Cheers,

David
-- 
David Fanning, Ph.D.
Fanning Software Consulting, Inc.
Coyote's Guide to IDL Programming: http://www.dfanning.com/
Sepore ma de ni thui. ("Perhaps thou speakest truth.")
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Subject: Re: Version Control Conundrum
Posted by David Fanning on Mon, 10 Dec 2007 15:03:21 GMT
View Forum Message <> Reply to Message

David Fanning writes:

>  Incidentally, about every other time I do this (and in
>  particular if I start up in the SNV Repository perspective
>  and want to switch to the IDL perspective), I throw an
>  error. The only way I have found I can then work, is to
>  start the Workshop all over again and go get another cup
>  of coffee while it "analyses code". I seem to be spending
>  more time in the bathroom than at my computer these days. :-(

Maybe this is more reproducible than I thought. It appears
that ANY time I start up in the SNV Repository perspective
I throw an error switching to the IDL perspective. (I thought
perhaps if I waiting a sufficient length of time to allow
code analysis I wouldn't have the problem, but that doesn't
seem to help.) The error, and their are two of these, is

   "An error occurred while automatically activating bundle
    com.rsi.idldt.ui (24)"

Cheers,

David
-- 
David Fanning, Ph.D.
Fanning Software Consulting, Inc.
Coyote's Guide to IDL Programming: http://www.dfanning.com/
Sepore ma de ni thui. ("Perhaps thou speakest truth.")

Subject: Re: Version Control Conundrum
Posted by David Fanning on Mon, 10 Dec 2007 15:13:29 GMT
View Forum Message <> Reply to Message

David Fanning writes:

>  Maybe this is more reproducible than I thought. It appears
>  that ANY time I start up in the SNV Repository perspective
>  I throw an error switching to the IDL perspective. (I thought
>  perhaps if I waiting a sufficient length of time to allow
>  code analysis I wouldn't have the problem, but that doesn't
>  seem to help.) The error, and their are two of these, is

A picture of me and my fierce, but beloved, seventh grade 
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English teacher, Mrs. Buchanan, sits just near my desk
where I can see it every day. I just noticed, after reading
this paragraph again, that she is frowning at me more
than usual this morning. :-(

Cheers,

David

P.S. The last time I mixed "their" and "there" up
was surely back in 1963!

-- 
David Fanning, Ph.D.
Fanning Software Consulting, Inc.
Coyote's Guide to IDL Programming: http://www.dfanning.com/
Sepore ma de ni thui. ("Perhaps thou speakest truth.")

Subject: Re: Version Control Conundrum
Posted by Vince Hradil on Mon, 10 Dec 2007 15:33:24 GMT
View Forum Message <> Reply to Message

On Dec 10, 8:45 am, David Fanning <n...@dfanning.com> wrote:
>  cgpadw...@gmail.com writes:
>>  I experimented with the eclipse perforce plugin for a while.  I don't
>>  recommend it.  I found it confusing and hard to use.  The eclipse
>>  perspectives are not a good interface for this type of thing.   What I
>>  would like to do is right click my file in the project and check it
>>  out or submit it, but with the perforce plugin you have to change
>>  perspectives. The perforce ui, p4v, is MUCH easier to use.
> 
>  Well, unless I am missing something (likely), you have to
>  change perspectives to work with the Subclipse plug-in, too.
> 
>  This could be made a lot less onerous if I could somehow
>  put the SNV Repository perspective in the *top* of the
>  Open Perspective menu instead of always having to choose
>  Other to get there, and then having to choose Other again
>  to get back to the IDL perspective. I have a feeling this
>  is probably a configurable item, but if so, I haven't found
>  the right magical incantation to make it happen.
> 
>  Cheers,
> 
>  David
>  --
>  David Fanning, Ph.D.
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>  Fanning Software Consulting, Inc.
>  Coyote's Guide to IDL Programming:http://www.dfanning.com/
>  Sepore ma de ni thui. ("Perhaps thou speakest truth.")

If your project is in a directory where there is a .svn file, i.e. a
checked-out directory, then the svn status shows up in the Project
Explorer.  So I don't use the SVN perspective, unless I want to browse
the entire repository - in which case I would probably just use
Tortoisesvn.

Subject: Re: Version Control Conundrum
Posted by Michael Galloy on Mon, 10 Dec 2007 15:35:34 GMT
View Forum Message <> Reply to Message

On Dec 10, 7:45 am, David Fanning <n...@dfanning.com> wrote:
>  cgpadw...@gmail.com writes:
>>  I experimented with the eclipse perforce plugin for a while.  I don't
>>  recommend it.  I found it confusing and hard to use.  The eclipse
>>  perspectives are not a good interface for this type of thing.   What I
>>  would like to do is right click my file in the project and check it
>>  out or submit it, but with the perforce plugin you have to change
>>  perspectives. The perforce ui, p4v, is MUCH easier to use.
> 
>  Well, unless I am missing something (likely), you have to
>  change perspectives to work with the Subclipse plug-in, too.

There is no need to change perspectives to use Subclipse to do
everyday tasks. Just right click on files/directories, go to "Team" in
the context menu, and select what you want to do.

Mike
--
www.michaelgalloy.com
Tech-X Corporation
Software Developer II

Subject: Re: Version Control Conundrum
Posted by David Fanning on Mon, 10 Dec 2007 15:42:27 GMT
View Forum Message <> Reply to Message

mgalloy@gmail.com writes:

>  There is no need to change perspectives to use Subclipse to do
>  everyday tasks. Just right click on files/directories, go to "Team" in
>  the context menu, and select what you want to do.
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Ah, "Team". I should have known. :-(

Thanks,

David

P.S. My "team" used to be the Broncos, but until yesterday
I've been disowning them. That's probably why I didn't check
this menu item. 

-- 
David Fanning, Ph.D.
Fanning Software Consulting, Inc.
Coyote's Guide to IDL Programming: http://www.dfanning.com/
Sepore ma de ni thui. ("Perhaps thou speakest truth.")

Subject: Re: Version Control Conundrum
Posted by David Fanning on Mon, 10 Dec 2007 15:48:57 GMT
View Forum Message <> Reply to Message

David Fanning writes:

>  mgalloy@gmail.com writes:
>  
>>  There is no need to change perspectives to use Subclipse to do
>>  everyday tasks. Just right click on files/directories, go to "Team" in
>>  the context menu, and select what you want to do.
>  
>  Ah, "Team". I should have known. :-(

Is "team" a technical computer term? Or is it just
like "Hey we are your plug-ins and we're on your
team now!" kind of a thing?

Cheers,

David
-- 
David Fanning, Ph.D.
Fanning Software Consulting, Inc.
Coyote's Guide to IDL Programming: http://www.dfanning.com/
Sepore ma de ni thui. ("Perhaps thou speakest truth.")

Subject: Re: Version Control Conundrum
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Posted by sbolin42 on Mon, 10 Dec 2007 15:52:54 GMT
View Forum Message <> Reply to Message

On Dec 10, 8:35 am, "mgal...@gmail.com" <mgal...@gmail.com> wrote:
>  On Dec 10, 7:45 am, David Fanning <n...@dfanning.com> wrote:
> 
>>  cgpadw...@gmail.com writes:
>>>  I experimented with the eclipse perforce plugin for a while.  I don't
>>>  recommend it.  I found it confusing and hard to use.  The eclipse
>>>  perspectives are not a good interface for this type of thing.   What I
>>>  would like to do is right click my file in the project and check it
>>>  out or submit it, but with the perforce plugin you have to change
>>>  perspectives. The perforce ui, p4v, is MUCH easier to use.
> 
>>  Well, unless I am missing something (likely), you have to
>>  change perspectives to work with the Subclipse plug-in, too.
> 
>  There is no need to change perspectives to use Subclipse to do
>  everyday tasks. Just right click on files/directories, go to "Team" in
>  the context menu, and select what you want to do.
> 
>  Mike
>  --www.michaelgalloy.com
>  Tech-X Corporation
>  Software Developer II

That is right.  Changing perspectives is not necessary.  You can open
any view you want in any perspective you want.  You can always open a
view in your favorite perspective using Window->Show View->Other...,
then select the view you want to open.  A perspective is just a
collection of views and you can customize the views you want in any
perspective.  You can have the "Debug" view in the IDL perspective, if
you like.  For Perforce, I mainly use the views:  "P4 Depots", "P4
Pending Changelists", and sometimes the "P4 Log Console".  The
Perforce "Pending Changelists" view allows one to see all the code
that is "checked out", or being edited by you.  You right-click a file
in this view, and then choose "Submit..." to check individual files or
entire changelists back into the repository.

-Scott

Subject: Re: Version Control Conundrum
Posted by David Fanning on Mon, 10 Dec 2007 16:05:38 GMT
View Forum Message <> Reply to Message

Scott Bolin writes:
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>  That is right.  Changing perspectives is not necessary.  You can open
>  any view you want in any perspective you want.  You can always open a
>  view in your favorite perspective using Window->Show View->Other...,
>  then select the view you want to open

Oh, OK, that's handy. This just illustrates one of
the biggest problems with graphical user interfaces:
you put a menu item on there and the damn idiots try to
use it! What are they thinking!? ;-)

Cheers,

David

-- 
David Fanning, Ph.D.
Fanning Software Consulting, Inc.
Coyote's Guide to IDL Programming: http://www.dfanning.com/
Sepore ma de ni thui. ("Perhaps thou speakest truth.")

Subject: Re: Version Control Conundrum
Posted by cgpadwick on Wed, 12 Dec 2007 20:03:19 GMT
View Forum Message <> Reply to Message

With Scott Bolin's help, I figured out why I was having so many
problems with the perforce eclipse plugin.  I had a project defined
*prior* to installing the perforce plugin.  You have to create the
projects from perforce - perforce doesn't know anything about existing
projects that you already have.  Thus when you edit a file, eclipse
asks you if you want to make the file writable, and perforce doesn't
know about it (it doesn't get opened for edit).

To fix this, here's what I did:
-I blew away my project (kept contents, just removed it from
eclipse).
-In the eclipse workbench, I clicked Window->Open Perspective->Other-
> Perforce to open the perforce perspective.
-In the P4 Depots window, I removed all the existing servers.  Then I
right clicked in the depot pane and clicked "New Server" and typed in
all the appropriate information.
-Now I was able to see the depot files in the depot pane.  I navigated
to the depot folder I wanted, right clicked, and clicked "Import as
Project".
-Then when I switched back to the IDL workbench, my project appears in
the project explorer.  Note that the location on the hard disk will be
the same as what was specified in the perforce client spec.
-Now I double click a file and it shows up in the editor.  If I then
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edit the file, eclipse no longer asks me if I want to edit it; rather,
it is opened for edit in perforce.  If I switch to the perforce
perspective then the file appears in the "P4 Pending Changelists"
pane.

You can choose to just show different views too, you don't have to
change perspectives.  I tend to just use the default perspectives for
each tool.

Subject: Re: Version Control Conundrum
Posted by David Fanning on Wed, 12 Dec 2007 20:27:16 GMT
View Forum Message <> Reply to Message

cgpadwick@gmail.com writes:

>  With Scott Bolin's help, I figured out why I was having so many
>  problems with the perforce eclipse plugin

I am about half-way though a detailed set of instructions for
installing a Subversion version control system on Windows XP
and accessing it from IDL 7.0. If I would have had these 
instructions before I started, I believe even I could have
done it in less than 10 tries. 

Anyway, this is part of a small experiment to see if anyone
will pay a couple of dollars for good instructions. My wife
tells me it is important to leverage all the time I have
been wasting lately. :-)

I could use a couple of testers, if anyone is interested in
trying this. I should have this finished later today.

Cheers,

David
 

-- 
David Fanning, Ph.D.
Fanning Software Consulting, Inc.
Coyote's Guide to IDL Programming: http://www.dfanning.com/
Sepore ma de ni thui. ("Perhaps thou speakest truth.")

Subject: Re: Version Control Conundrum
Posted by Ben Panter on Thu, 13 Dec 2007 09:07:19 GMT
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View Forum Message <> Reply to Message

David Fanning wrote:
>  cgpadwick@gmail.com writes:
>  
>>  With Scott Bolin's help, I figured out why I was having so many
>>  problems with the perforce eclipse plugin
>  
>  I am about half-way though a detailed set of instructions for
>  installing a Subversion version control system on Windows XP
>  and accessing it from IDL 7.0. If I would have had these 
>  instructions before I started, I believe even I could have
>  done it in less than 10 tries. 
>  
>  Anyway, this is part of a small experiment to see if anyone
>  will pay a couple of dollars for good instructions. My wife
>  tells me it is important to leverage all the time I have
>  been wasting lately. :-)
>  
>  I could use a couple of testers, if anyone is interested in
>  trying this. I should have this finished later today.
>  
>  Cheers,
>  
>  David
>   
>  

Morning David,

I've not played with the final release version of 7 yet - not been 
installed at work yet - but I had great difficulty with CVS in the later 
versions of the beta. All my code sits in a CVS archive, happily 
arranged into four 'modules'. The various astrolib, coyote, pan etc. 
routines are in a further directory, 'KEEP', which isn't under CVS.

How this is all going to work when v7 is installed is worrying me. I 
suspect that there will be a day spent cursing: beer money for a simple 
instruction sheet (CVS rather than SVN, sorry!) would be a sound investment.

Ben

-- 
Ben Panter, Edinburgh, UK.
Email false, http://www.benpanter.co.uk
or you could try ben at ^^^^^^^^^^^^^^^
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Subject: Re: Version Control Conundrum
Posted by David Fanning on Thu, 13 Dec 2007 14:27:59 GMT
View Forum Message <> Reply to Message

Ben Panter writes:

>  How this is all going to work when v7 is installed is worrying me. I 
>  suspect that there will be a day spent cursing: beer money for a simple 
>  instruction sheet (CVS rather than SVN, sorry!) would be a sound investment.

Nah. If you already have the repository, just download
the plug-in from the ITTVIS web page. It will be a slam dunk. :-)

Cheers,

David

-- 
David Fanning, Ph.D.
Fanning Software Consulting, Inc.
Coyote's Guide to IDL Programming: http://www.dfanning.com/
Sepore ma de ni thui. ("Perhaps thou speakest truth.")
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