
Subject: Source Control IDL 8.1
Posted by David Fanning on Wed, 04 May 2011 16:00:18 GMT
View Forum Message <> Reply to Message

Folks,

I had heard that IDL 8.1 had source control management
plug-ins for Subversion and other management tools, but
I can find no mention of this anywhere in the documentation.

Does anyone know how to use or install these tools
in the Workbench? Does anyone know where some documentation
about this process might be?

Thanks.

Cheers,

David

-- 
David Fanning, Ph.D.
Fanning Software Consulting, Inc.
Coyote's Guide to IDL Programming: http://www.idlcoyote.com/
Sepore ma de ni thui. ("Perhaps thou speakest truth.")

Subject: Re: Source Control IDL 8.1
Posted by R.Bauer on Thu, 05 May 2011 15:29:11 GMT
View Forum Message <> Reply to Message

Am 05.05.2011 13:36, schrieb Reimar Bauer:
>  Am 04.05.2011 18:40, schrieb Chris Torrence:
>>  Hi David,
>> 
>>  Yes, that's correct. IDL 8.1 ships with plugins for CVS, Git,
>>  Perforce, and Subversion. We ran out of time to do extensive
>>  documentation for these. We are currently working on some
>>  instructional videos, but it will be a while.
>> 
>>  In the meantime, if you go into the Workbench, under Window->Source
>>  Control Tools, you can pick the tool you are interested in. It will
>>  then install all of the required plugins. When you restart the
>>  Workbench, you will have access to all of the "views" appropriate to
>>  that SCM tool. Look under Window->Show View->Other... to see the list
>>  of available views for your SCM.
>> 

Page 1 of 15 ---- Generated from comp.lang.idl-pvwave archive

http://idlcoyote.com/comp.lang.idl-pvwave/index.php?t=usrinfo&id=4003
http://idlcoyote.com/comp.lang.idl-pvwave/index.php?t=rview&th=32320&goto=75785#msg_75785
http://idlcoyote.com/comp.lang.idl-pvwave/index.php?t=post&reply_to=75785
http://idlcoyote.com/comp.lang.idl-pvwave/index.php?t=usrinfo&id=2825
http://idlcoyote.com/comp.lang.idl-pvwave/index.php?t=rview&th=32320&goto=75946#msg_75946
http://idlcoyote.com/comp.lang.idl-pvwave/index.php?t=post&reply_to=75946
http://idlcoyote.com/comp.lang.idl-pvwave/index.php


>>  Here are some links that might help in using the plugins:
>>  http://www.eclipse.org/eclipse/platform-cvs/
>>  http://www.eclipse.org/egit/
>>  http://www.perforce.com/perforce/products/p4eclipse.html
>>  http://www.eclipse.org/subversive/
>> 
>  
>  Is this just a typo or why is mercurial missing?
>  
>  It definitly works as you can see at
>  
>  https://idlsource.fz-juelich.de/admin/idlde.html
>  
>  In 8.0 I have had to tweak the configuration manually.
>  
>  
>  Reimar
>  
>>  Hope this helps!
>>  Cheers,
>>  Chris
>>  ITTVIS
>  

Ok, again until it is implemented

In case you want to use mercurial just do the following steps with idl8.1

copy of file
com.vectrace.MercurialEclipse_1.7.1.v201012101420.jar

to
/usr/local/itt/idl/idl/idlde/plugins

and

copy of directory
mercurialeclipse_1.7.1.v201012101420

to
/usr/local/itt/idl/idl/idlde/features

then add to
 /usr/local/itt/idl/idl/idlde/configuration.linux.x86_64/conf ig.ini
to the parameter starting with
osgi.bundles=

at the end of the line append similiar to the others
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 ,reference\:file\:com.vectrace.MercurialEclipse_1.7.1.v20101 2101420.jar@4

The next parameter is the eclipse.p2.data.area=

I used the same files as I got by using
Eclipse SDK

Version: 3.5.2
Build id: M20100211-1343

If you now choose File - Import  you see Mercurial in the dialog

Reimar

Subject: Re: Source Control IDL 8.1
Posted by Scott[1] on Thu, 05 May 2011 15:30:31 GMT
View Forum Message <> Reply to Message

David, please try disabling Subversion again, closing the workbench
and deleting the following folders (if they exist):
C:\Documents and Settings\<username>\.idl\itt\features
C:\Documents and Settings\<username>\.idl\itt\idlworkbench-config-
idl8.1.0
C:\Documents and Settings\<username>\.idl\itt\p2
C:\Documents and Settings\<username>\.idl\itt\plugins
and the file:
C:\Documents and Settings\<username>\.idl\itt\artifacts.xml

Then restart the workbench and enable Subversion again.

Sorry this may cause you to lose some 8.1 preference settings but
should reset things enough to fix your Subversion issues. I just tried
these steps on an 8.1 install and it worked for me.

-Scott

Subject: Re: Source Control IDL 8.1
Posted by R.Bauer on Thu, 05 May 2011 15:42:59 GMT
View Forum Message <> Reply to Message

Am 05.05.2011 17:29, schrieb Reimar Bauer:
>  Am 05.05.2011 13:36, schrieb Reimar Bauer:
>>  Am 04.05.2011 18:40, schrieb Chris Torrence:
>>>  Hi David,
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>>> 
>>>  Yes, that's correct. IDL 8.1 ships with plugins for CVS, Git,
>>>  Perforce, and Subversion. We ran out of time to do extensive
>>>  documentation for these. We are currently working on some
>>>  instructional videos, but it will be a while.
>>> 
>>>  In the meantime, if you go into the Workbench, under Window->Source
>>>  Control Tools, you can pick the tool you are interested in. It will
>>>  then install all of the required plugins. When you restart the
>>>  Workbench, you will have access to all of the "views" appropriate to
>>>  that SCM tool. Look under Window->Show View->Other... to see the list
>>>  of available views for your SCM.
>>> 
>>>  Here are some links that might help in using the plugins:
>>>  http://www.eclipse.org/eclipse/platform-cvs/
>>>  http://www.eclipse.org/egit/
>>>  http://www.perforce.com/perforce/products/p4eclipse.html
>>>  http://www.eclipse.org/subversive/
>>> 
>> 
>>  Is this just a typo or why is mercurial missing?
>> 
>>  It definitly works as you can see at
>> 
>>  https://idlsource.fz-juelich.de/admin/idlde.html
>> 
>>  In 8.0 I have had to tweak the configuration manually.
>> 
>> 
>>  Reimar
>> 
>>>  Hope this helps!
>>>  Cheers,
>>>  Chris
>>>  ITTVIS
>> 
>  
>  Ok, again until it is implemented
>  
>  In case you want to use mercurial just do the following steps with idl8.1
>  
>  copy of file
>  com.vectrace.MercurialEclipse_1.7.1.v201012101420.jar
>  
>  to
>  /usr/local/itt/idl/idl/idlde/plugins
>  
>  and
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>  
>  copy of directory
>  mercurialeclipse_1.7.1.v201012101420
>  
>  to
>  /usr/local/itt/idl/idl/idlde/features
>  
>  then add to
>   /usr/local/itt/idl/idl/idlde/configuration.linux.x86_64/conf ig.ini
>  to the parameter starting with
>  osgi.bundles=

it is this one:
osgi.framework.extensions=
not osgi.bundles

sorry for the c/p failure

And it works also with the 1.8.1 version of the mercurial pluging

Reimar

>  
>  at the end of the line append similiar to the others
>  
>   ,reference\:file\:com.vectrace.MercurialEclipse_1.7.1.v20101 2101420.jar@4
>  
>  The next parameter is the eclipse.p2.data.area=
>  
>  I used the same files as I got by using
>  Eclipse SDK
>  
>  Version: 3.5.2
>  Build id: M20100211-1343
>  
>  If you now choose File - Import  you see Mercurial in the dialog
>  
>  Reimar
>  
> 

Subject: Re: Source Control IDL 8.1
Posted by David Fanning on Thu, 05 May 2011 15:53:52 GMT
View Forum Message <> Reply to Message

Scott E writes: 
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>  David, please try disabling Subversion again, closing the workbench
>  and deleting the following folders (if they exist):
>  C:\Documents and Settings\<username>\.idl\itt\features
>  C:\Documents and Settings\<username>\.idl\itt\idlworkbench-config-
>  idl8.1.0
>  C:\Documents and Settings\<username>\.idl\itt\p2
>  C:\Documents and Settings\<username>\.idl\itt\plugins
>  and the file:
>  C:\Documents and Settings\<username>\.idl\itt\artifacts.xml
>  
>  Then restart the workbench and enable Subversion again.
>  
>  Sorry this may cause you to lose some 8.1 preference settings but
>  should reset things enough to fix your Subversion issues. I just tried
>  these steps on an 8.1 install and it worked for me.

Hi Scott,

I appreciate your help with this. 

The only one of these folders that was in the .idl/itt directory
was the p2 folder, which I deleted.

When I restarted IDL, I could then get to the connector dialog
and I selected the two choices there for the version of
Subversion (1.6) I have on my machine. I got the same
error message when I installed yesterday (e.g., "something" is missing).
So, I deleted the Windows only connector and asked the dialog
to carry on. This seems to have installed something, because
now I have a repository viewer in my Workbench, etc.

I found an Import button under the file menu, and that lead
me to a dialog that asked me to input the URL of the repository,
which I did (http://idl-coyote.googlecode.com/svn/trunk/coyote).

This has brought me to a Select Resource dialog which shows the
URL of the repository, with the Head Revision selected, but
the Next button is grayed out! All I can do is go back or cancel.

Going back puts me back in the Enter Repository Location Information
dialog with the correct URL selected.

So, not sure what to do next. :-(

Thanks,

David

Page 6 of 15 ---- Generated from comp.lang.idl-pvwave archive

http://idlcoyote.com/comp.lang.idl-pvwave/index.php


-- 
David Fanning, Ph.D.
Fanning Software Consulting, Inc.
Coyote's Guide to IDL Programming: http://www.idlcoyote.com/
Sepore ma de ni thui. ("Perhaps thou speakest truth.")

Subject: Re: Source Control IDL 8.1
Posted by David Fanning on Fri, 06 May 2011 16:23:18 GMT
View Forum Message <> Reply to Message

David Fanning writes: 

>  So, not sure what to do next. :-(

OK, I think Scott has give up on me. Has anyone
managed to get a Subversion repository linked up
to IDL 8.1? I'd be happy to write down the steps
so the rest of us can do it, too. :-)

Cheers,

David

-- 
David Fanning, Ph.D.
Fanning Software Consulting, Inc.
Coyote's Guide to IDL Programming: http://www.idlcoyote.com/
Sepore ma de ni thui. ("Perhaps thou speakest truth.")

Subject: Re: Source Control IDL 8.1
Posted by Matt[2] on Fri, 06 May 2011 16:49:37 GMT
View Forum Message <> Reply to Message

On May 6, 10:23 am, David Fanning <n...@idlcoyote.com> wrote:
>  David Fanning writes:

>  OK, I think Scott has give up on me. Has anyone
>  managed to get a Subversion repository linked up
>  to IDL 8.1? I'd be happy to write down the steps
>  so the rest of us can do it, too. :-)
> 

As soon as you get that, try to get mulgasoft's emacs+ into it?  I
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*might* try the workbench if I could type in it....

I know you're not that busy right?

Cheers,
Matt

Subject: Re: Source Control IDL 8.1
Posted by Michael Galloy on Fri, 06 May 2011 17:53:11 GMT
View Forum Message <> Reply to Message

On 5/6/11 10:23 AM, David Fanning wrote:
>  David Fanning writes:
> 
>>  So, not sure what to do next. :-(
> 
>  OK, I think Scott has give up on me. Has anyone
>  managed to get a Subversion repository linked up
>  to IDL 8.1? I'd be happy to write down the steps
>  so the rest of us can do it, too. :-)
> 
>  Cheers,

It works for me on Mac OS X, but I didn't have to do anything special. I 
did choose just one connector (the latest SVNKit).

Mike
-- 
Michael Galloy
www.michaelgalloy.com
Modern IDL, A Guide to Learning IDL: http://modernidl.idldev.com
Research Mathematician
Tech-X Corporation

Subject: Re: Source Control IDL 8.1
Posted by penteado on Fri, 06 May 2011 18:13:09 GMT
View Forum Message <> Reply to Message

On May 6, 2:53 pm, Michael Galloy <mgal...@gmail.com> wrote:
>  It works for me on Mac OS X, but I didn't have to do anything special. I
>  did choose just one connector (the latest SVNKit).

Same here, in Linux.
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Subject: Re: Source Control IDL 8.1
Posted by David Fanning on Fri, 06 May 2011 18:16:41 GMT
View Forum Message <> Reply to Message

Paulo Penteado writes: 

>  Same here, in Linux.

I'll try starting from scratch again and see if I have
any better luck.

Cheers,

David

-- 
David Fanning, Ph.D.
Fanning Software Consulting, Inc.
Coyote's Guide to IDL Programming: http://www.idlcoyote.com/
Sepore ma de ni thui. ("Perhaps thou speakest truth.")

Subject: Re: Source Control IDL 8.1
Posted by R.Bauer on Mon, 09 May 2011 13:54:17 GMT
View Forum Message <> Reply to Message

Am 06.05.2011 20:16, schrieb David Fanning:
>  Paulo Penteado writes: 
>  
>>  Same here, in Linux.
>  
>  I'll try starting from scratch again and see if I have
>  any better luck.
>  
>  Cheers,
>  
>  David
>  
>  

David

try mercurial:)

http://mercurial.selenic.com/

Reimar
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Subject: Re: Source Control IDL 8.1
Posted by David Fanning on Mon, 09 May 2011 14:12:59 GMT
View Forum Message <> Reply to Message

Reimar Bauer writes: 

>  David
>  
>  try mercurial:)
>  
>  http://mercurial.selenic.com/

Well, I am trying to keep everything of a piece. :-)

Dick Jackson gave me a tip that appears to have worked.
Apparently, once you have installed the Subversion
plug-in, it is not possible (at least no one I know has
been successful) to import a directory from a repository.

But, if you import a directory in some other way
(I used TortoiseSVN), then you make a project in
IDL out of that directory, the Subversion plug-in
does seem to work in this case. At least when I open
the project up I can see the repository connected to
the project, and what must be version numbers associated
with each file. I haven't yet tried to check a change
in, but maybe today.

I am *trying* to use IDL 8.1, but it's an effort. This
version does appear to be more stable on my Windows
machine (they have again separated the JAVA and IDL
processes on Windows machines, which was the source of
so much fragility in IDL 8.0), but I am still struggling
with annoyances. The Compile/Run buttons don't work,
for example, if you run a main-level program with an
error in it. And I have struggled to make sense of how
to set and remove breakpoints. They seem to have a mind
of their own, and not a very big mind at that. :-(

Cheers,

David

-- 
David Fanning, Ph.D.
Fanning Software Consulting, Inc.
Coyote's Guide to IDL Programming: http://www.idlcoyote.com/
Sepore ma de ni thui. ("Perhaps thou speakest truth.")
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Subject: Re: Source Control IDL 8.1
Posted by David Fanning on Mon, 09 May 2011 14:17:05 GMT
View Forum Message <> Reply to Message

David Fanning writes: 

>  But, if you import a directory in some other way
>  (I used TortoiseSVN), then you make a project in
>  IDL out of that directory, the Subversion plug-in
>  does seem to work in this case.

Although, I should point out that I did manage to get
my Coyote directory installed in IDL 8.1 in this way.
But, when I went through the identical steps to get
my Catalyst directory installed, IDL went into some
kind of tail spin when it tried to make a project out
of it. I let it churn for a couple of hours before I
killed the process.

I haven't tried it again this morning, as I'm trying
to get some work done and I always use IDL 7.1.1 for
that. :-)

Cheers,

David

-- 
David Fanning, Ph.D.
Fanning Software Consulting, Inc.
Coyote's Guide to IDL Programming: http://www.idlcoyote.com/
Sepore ma de ni thui. ("Perhaps thou speakest truth.")

Subject: Re: Source Control IDL 8.1
Posted by David Fanning on Mon, 09 May 2011 14:24:47 GMT
View Forum Message <> Reply to Message

David Fanning writes: 

>  Although, I should point out that I did manage to get
>  my Coyote directory installed in IDL 8.1 in this way.
>  But, when I went through the identical steps to get
>  my Catalyst directory installed, IDL went into some
>  kind of tail spin when it tried to make a project out
>  of it. I let it churn for a couple of hours before I
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>  killed the process.

I just tried it again. The directory was added almost
instantaneously. Go figure. 

Cheers,

David

-- 
David Fanning, Ph.D.
Fanning Software Consulting, Inc.
Coyote's Guide to IDL Programming: http://www.idlcoyote.com/
Sepore ma de ni thui. ("Perhaps thou speakest truth.")

Subject: Re: Source Control IDL 8.1
Posted by Scott[1] on Mon, 09 May 2011 16:52:21 GMT
View Forum Message <> Reply to Message

On May 6, 10:23 am, David Fanning <n...@idlcoyote.com> wrote:
>  David Fanning writes:
>>  So, not sure what to do next. :-(
> 
>  OK, I think Scott has give up on me. Has anyone
>  managed to get a Subversion repository linked up
>  to IDL 8.1? I'd be happy to write down the steps
>  so the rest of us can do it, too. :-)
> 
>  Cheers,
> 
>  David
> 
>  --
>  David Fanning, Ph.D.
>  Fanning Software Consulting, Inc.
>  Coyote's Guide to IDL Programming:http://www.idlcoyote.com/
>  Sepore ma de ni thui. ("Perhaps thou speakest truth.")

Sorry David, I did not give up on you. I "replied to author" twice
giving you my email and asking for more specific information, but I
guess those went to an email account you don't keep up with. Sorry.
Glad you seem to have got it working.
-Scott
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Subject: Re: Source Control IDL 8.1
Posted by David Fanning on Mon, 09 May 2011 17:08:37 GMT
View Forum Message <> Reply to Message

Scott E writes: 

>  Sorry David, I did not give up on you. I "replied to author" twice
>  giving you my email and asking for more specific information, but I
>  guess those went to an email account you don't keep up with. Sorry.
>  Glad you seem to have got it working.

Oh, OK. Sorry Scott. Using a non-functioning return
e-mail in newsgroups is the only way I know to keep
the spam traffic to a minimum (now only 80% of my
total traffic, down from 98%). :-)

Most people don't have too much trouble finding me,
but occasionally it gets me into trouble. Sorry, again.

Cheers,

David 

-- 
David Fanning, Ph.D.
Fanning Software Consulting, Inc.
Coyote's Guide to IDL Programming: http://www.idlcoyote.com/
Sepore ma de ni thui. ("Perhaps thou speakest truth.")

Subject: Re: Source Control IDL 8.1
Posted by Scott[1] on Mon, 09 May 2011 17:18:24 GMT
View Forum Message <> Reply to Message

On May 9, 11:08 am, David Fanning <n...@idlcoyote.com> wrote:
>  Scott E writes:
>>  Sorry David, I did not give up on you. I "replied to author" twice
>>  giving you my email and asking for more specific information, but I
>>  guess those went to an email account you don't keep up with. Sorry.
>>  Glad you seem to have got it working.
> 
>  Oh, OK. Sorry Scott. Using a non-functioning return
>  e-mail in newsgroups is the only way I know to keep
>  the spam traffic to a minimum (now only 80% of my
>  total traffic, down from 98%). :-)
> 
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>  Most people don't have too much trouble finding me,
>  but occasionally it gets me into trouble. Sorry, again.
> 
>  Cheers,
> 
>  David
> 
>  --
>  David Fanning, Ph.D.
>  Fanning Software Consulting, Inc.
>  Coyote's Guide to IDL Programming:http://www.idlcoyote.com/
>  Sepore ma de ni thui. ("Perhaps thou speakest truth.")

Ah, I should have known. :-) Anyway hope you're enjoying using
Subversion from workbench now.
-Scott

Subject: Re: Source Control IDL 8.1
Posted by markb77 on Fri, 11 Jul 2014 12:25:21 GMT
View Forum Message <> Reply to Message

The same thing happened to me.. I selected the wrong Subversion connector the first time the
SVN installation dialog came up.  Now, I can't get IDL to show me that dialog again, despite the
fact that I have uninstalled all of the SVN connectors.

I'm using IDL 8.3.  Any suggestions?  Deleting the aforementioned files doesn't seem to help.

thanks
Mark

Subject: Re: Source Control IDL 8.1
Posted by markb77 on Fri, 11 Jul 2014 13:42:16 GMT
View Forum Message <> Reply to Message

On Friday, July 11, 2014 2:25:21 PM UTC+2, superchromix wrote:
>  The same thing happened to me.. I selected the wrong Subversion connector the first time the
SVN installation dialog came up.  Now, I can't get IDL to show me that dialog again, despite the
fact that I have uninstalled all of the SVN connectors.
>  
>  
>  
>  I'm using IDL 8.3.  Any suggestions?  Deleting the aforementioned files doesn't seem to help.
>  
>  
>  
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>  thanks
>  
>  Mark

I eventually fixed this by deleting my workspace..

Page 15 of 15 ---- Generated from comp.lang.idl-pvwave archive

http://idlcoyote.com/comp.lang.idl-pvwave/index.php

